Final part offset from expected location

As the title suggests I am at a complete loss. I am posting here even though less people will see it because I HATE the fact that anything I post in the facebook group is public and goes out to all of my facebook friends and family who get to learn about my machine problems…that is so lame. I have been struggling for hours, and I do mean hours on how in the heck I can get fusion to orient correctly so that I can machine a simple little cube from some round stock. I am at the end of my rope and my frustration level can not even be understated. I have probably spent in excess of 15 hours trying to figure this out and still I am nowhere. Here is what I want to do and I dont think it should be so difficult. I want to hold a piece of round stock in the ER40 collet chuck, machine flats on 5 sides, and have basically a little cube machined out of the middle of the round bar stock. The problem I am having is that no matter what I do I end up with a part that is not centered in the round bar. I have watched every video I can find. read every guide, followed every tutorial, and still I am not much further along than I was several days ago. In short I am frustrated beyond words, and really hate this whole machine at this point. I am yet to find any kind of turotial that explains how to set up your part orientation and axis in fusion to allow for round bar stock in the collet and that seems like such a basic operation, and an easy way to hold bar stock, and yet I cant find a guide on how I need to do it. I managed to stumble thru on my own, and get a part oriented in fusion in such a way that it would actually run in the simulator and not causing any errors. The cut paths appeared to perfectly follow the contours of my part, and it was happy to run the g code. Then when I cut the actual part out on the V2-10 it is not centered in the bar stock. It is off on 2 axis by about .1inches or so. For the life of me I do not understand. I have ensured I dont have any offsets applied. Restarted the machine and the program several times, re loaded the code, etc. Nothing and I mean nothing works. If I come across as angry I am. This should not be this difficult, and the lack of information about how to strategize your part location in fusion so that all of the axis and work offsets will line up in the V2 is beyond irritating. Many of the older videos reference the machine specific work center point offset that you must know, but that information seems to be out of date and not relevant now with the kinetic control? Please tell me what I am missing because I am this close to tossing a several thousand dollar machine in the trash can, like literally. I am not a stupid person but spending less than a week with this thing sure has made me feel like one. I have my origin centered on the round bar stock, and as I said it runs perfectly in the simulator. Why does it not work in real life? Thanks for reading my rant, and for any suggestions you may be able to offer.

Hi Trevor,

I am sorry to hear that you are having some trouble getting your machine to cut the part the way you expect. 5 axis machining can definitely be challenging, especially on the programming side of things.

To aid in reducing the learning curve of learning 5 axis machining, we have put together a “Pocket NC 101” online course that walks users through the steps necessary to machine a part on the Pocket NC. This course has really helped get folks off the ground and it includes an example of how to set up a part like the one you are attempting. You can learn more about the course here - Courses — Penta Machine Co.

I would definitely recommend taking the course, I think it will help a lot. It is based around Fusion 360 and Kinetic Control. If you do not have Kinetic Control, reach out to me at and we can talk about some alternate options.

I did not realize that there was a paid online course. I will consider it. I dont even care about the 70 dollars, but at some point I have to quit throwing money at this and realize that is is simply not going to work for me. I wish there were a few more details on what the course covers ie, can I start with round stock and make a part? I also see that one of the spiral parts is included. That is neat an all but without the 2145 dollar version of fusion that is simply not going to be possible. One more thing to be frustrated about. I bought one of these too late after most of the 5 axis functionality was stripped away from the free version.

Trevor, can you post your tool offsets, work offsets and G code that isn’t demonstrating the behavior you’re expecting?

Here is the fusion file, as well as the gcode
test part2.ngc (70.6 KB)
test part2.stl (89.9 KB)
Pocket NC test cube 2 v5.f3z (851.4 KB)

Here is another fusion 360 file I created. I cant even get this one to post. I feel like I have my part oriented correctly, but something is very wrong as it wont even generate the code when I attempt to post. If anybody can look at it and tell me what I am doing wrong I would so appreciate it!
Fusion test3.f3z (450.0 KB)

Can you also please post your tool offsets and work offsets as they are set on your machine?

Sure thing, sorry.

Thanks Trevor, I appreciate it! It looks to me that the part is shifted some how in Fusion. If you look carefully at your part in the simulator, you can see that it is offset from center. I’ve added a cylinder to your part to help visualize it (you should be able to click the Open Attachments In Pocket NC Simulator button on this post to see it).

test part2.ngc (70.6 KB)
test part2.stl (96.0 KB)

We took a look at your Fusion file and your Setup origin is set to the Model’s origin, which looks to be an arbitrary point in space. I recommend taking a look at this section of the First Part tutorial:

You’ll likely want to select the center point on the top of the stock. You’ll then need to locate the Y work offset on your stock:

1 Like

John, thank you for your reply. This evening when I can approach it with a clearer mindset I will take a look at all of your suggestions and implement them and let you know what my results are. Thanks again for helping me through my time of frustration.

You’re welcome, Trevor! We’re happy to help! There are a lot of details that need to be right with 5-axis machining and it definitely can be frustrating to not know which one isn’t quite right.

Let us know if you run into any other problems.

1 Like

Your advice was earlier about the WCS was very helpful. I wanted to try another design almost like it, but not quite the same. On this one I have another problem I cant figure out on my own, The very last operation here (face9) wont post because it says the orientation is not supported, I feel like I did the same thing for each of the faces, but once again I MUST BE missing something dumb once again.
Fusion test part 4.f3z (453.9 KB)

Your Setup should reflect how the part is mounted in the machine with the rotary axes at 0. Then use the tool orientation of each tool path to describe how the part should be oriented while cutting. In this case it looks like your Setup isn’t aligned properly. I imagine the tool paths that do post, won’t do what you expect and the last one doesn’t even post because it’s attempt to put the machine into an orientation that it can’t reach.

AHHH, I swore I had it, yet somehow I did not. I just fixed it, and then fixed all of the ensuing operations which were in turn messed up! Now it posts out fine. I will try running it tomorrow and see what I come up with. After running it thru the simulator of course! Thanks for all the help, and I hope and promise to actually be good at this someday!
1001.ngc (22.6 KB)

With all of the help I think I may have it! Just programmed and then cut my first part that is just how I wanted it! I could possibly go a little bit thinner on the magic tab at the bottom but for now I didn’t want to push it. So great to see this thing move as I had envisioned. Thanks for all the help! It hasn’t been easy, not that anything worthwhile ever is.


Nice work, Trevor! Can’t wait to see what you make next!

1 Like

Well just when I thought I thought I might have this figured out and be on my way to making parts I was proven wrong once again. I set out creating a new model in fusion with a CAM setup just like in the previous example that worked for me…I thought so at least. This time I created a slightly more complicated part but still nothing too elaborate. Basically it just has a front and back side with a few features, and 2 tools this time. I got it posted fine, and it looks right in the simulator, but when I go to the machine I have problems. It completes the first operation, and then pauses. I am not prompted in any way to insert a new tool, but I assumed that is what it wanted so I inserted the next tool (previously probed for offset) and pressed the flashing green button. The spindle starts for about half a second and then I get all kinds of errors about joint 2 move exceeding limits. It looks to me like the coordinates requested at around line 250 after the change to a 1mm tool are reasonable and I dont understand why it faults. Also is there a way to configure the post processor so that it pops up with a message such as insert Tool “X”? I imagine on long programs with multiple tool changes it could quickly get very confusing if you are not prompted. Here is the fusion file as well as the gcode (looks Ok in the simulator) Thanks
X Brace.ngc (76.9 KB)
X brace.f3z (1.1 MB)

Sounds like you have multiple tools. Did you measure both of them ahead of time?

There should be an option in the Fusion post to Show Tool Number Popup, which will throw up a message in the UI with a notification in the bottom right that you can click on to bring the message up again.

That is correct. This time I have implemented the use of two tools instead of one. The first portion of the program runs fine but then after the tool change I get all kinds of out of position errors. I uploaded the G-Code and the fusion file to my previous post. If you have the chance would you please take a look at them and see if something stands out to you as obvious. I felt confident I had implemented all of the learnings from your previous messages but apparently I am still missing a piece of the puzzle. Both tools were probed ahead of time and have the correct offset showing within the kinetic software. Thanks again for your help.