Machine won't boot after installing new micro SD card

The instructions are pretty simple but something isn’t right. I inserted the micro SD card and turned the V2-10 on, waiting for a boot. Nothing happened. I removed the micro SD and the machine booted in legacy mode just fine. I tried this 3 times wih no response when the micro SD card is snapped in.
Thinking I missed something, I looked back through the included directions and saw the steps to remove the beagleboard and hold down the boot button on the back side. It wasn’t until after I went through this that I realized these steps were for older machines (1800 and lower).
I once again tried the micro SD setup and still no boot. I removed the micro SD and it again booted in legacy. (And the micro SD contacts are facing outward)
Machine #1870

How long did you let the board try to boot?

You might check the sd card by plugging it into you computer and see if windows throws a fit about not being able to read the filesystems (DO NOT FORMAT if windows asks you to)

I meant to reply sooner but I saw something shiny and there it went.
The Micro-SD card did display the file system error message and at first it was thought to be a bad SD card (or file on it). I’ve been working with Chuck at Penta and after flashing a new Micro-SD, still without any response, he suspects a bad SD holder or connection and is sending a replacement BeagleBone Board with a known good Kinetic Control.
My machine boots into legacy without the SD card in place which means that BeagleBone Board is basically good.
I’ll let you know if it works.