Problem setting WCS with Mastercam


I’m doing a bachelors thesis on 5-axis milling and i am using the Pocket NC V2-50 and absolutely loving it! I’ve succesfully machined many parts from a cylindrical stock without any problems. Now however i’m trying to use a rectangular stock of about 100x60x40.

I’m a little bit confused on how to set the G54 on the machine because on the cylindrical stock i only had to adjust Y-axis, but in this case all 3 of them. First i’ve set the correct TLO with the correct tool attached and then what i have done is i had a 6mm diameter tool attached and i brought the side of the tool barely touching the top of the stock and set Y G54 there as +4mm (3mm from tool and 1mm because my CAM zero is 1mm below stock), exactly the same thing as i did with cylindrical stock. Next i brought the tool from the side barely touching and set X as -3. And lastly brought the tip of the tool barely touching the tool side of the stock and set Z to 0. I believe i have followed the instructions correctly.

This is why i suspect that my problem is in setting the WCS axis directions on Mastercam. I have done all the toolpaths from the same plane as the Z pointing up.(pic) I have read the Fusion instructions multiple times and i always wonder about the setup that’s done before making any toolpaths. It’s very clear in the practice part where you set the setup Z pointing the tool and then the toolpaths from other directions. So i have tried setting WCS in mastercam the same way and then making another plane Z up but that doesn’t work. Or then i just don’t know how to do it correctly.

And the actual problem is that when i make the program Z pointing up it works in the simulator very well, the table turns correctly and everything looks good. Then i start the program on the machine itself and it is almost working but there is a little hiccup. The depth of cut is way too deep and the Y axis starts from the wrong place. X axis seems to be working correctly. I’ll attach some pictures, Mastercam program and the .ngc so you can take a closer look.

(I’ll upload the attachments and rest of pictures once i get permission to do so!)

Hey @Deepcuts

I do not know enough about Mastercam to help with your question but we have just allowed you to upload more attachments, so feel free to do so whenever.

1 Like


Here you can see the depth of the first cut and the height of Y is quite wrong. The depth should only be about 0.25mm and start from ‘‘on top’’ of the part.

And here i set the G54. Z to the side with writing on it. X to this side towards us and Y to the top as described above.

ILE1_OK_600.ngc (767.4 KB)
ILE1_OK.emcam (4.4 MB)

I program with Mastercam.
Can you access and send a private message/ email?