Siemens NX - unwanted offset in Y axis


I am learning how to prepare CAM setup in Siemens NX for manufacturing in 5 axis mode and no matter what I do, I am always having 0,35 mm (0,014 IN) offset in Y axis, once the blank stock is oriented for machining.

In picture below, you can see my main MCS setup. Its in the centre of blank stock, Z axis pointing to millig tool. Also the manufactured part is centered in the blank stock. B-table offset is set into machining assembly.


Once I start manufacturing, A table turns 90° and part is milled in planar mode. For this I have set a local MCS, which is placed in the same position like Main MCS, just axis orientation is different. Setup of local MCS is in the picture below.


And once the machine starts milling, even that machined part is properly centred to the Main MCS, there is 0,35mm offset in Y axis . And I see this in Y axis only, the rest is fine.

My questions:

Is it necessary to index X,Y and Z axis before work, if I am using machine centrepoint as starting point?

If not, does anyone has any idea, what should be the root cause of this offset?

Thank you very much for support, Greeting from Czech Republic :wink:

Hello @Jiri.L
When you have a local mcs that’s a different orientation to the main mcs I assume you want to use the orientation of the local mcs? In that case change the “special output” of the local mcs output type to csys rotation.

Are you using the free kit from post hub? This would be a good starting point as it’s proven on many pnc’s already. Also edit the expression in the machine kit top level assembly file to match your center of rotation offset provided by Penta Machine.

As Linux cnc doesn’t have too many features you probably don’t need to change the orientation of the local mcs, just the position and “special output” type to “Fixture Offset” and change the offset number to what you like for workpiece origin if needed. . (53 +n) so 1 would be G54, 2 would be G55 etc.

b axis offset

Hello @Paul,

thank you for response. I’ll try to set CAM according your advice and try to manufacture part.

I downloaded postprocessor from Siemens library, where free kit should be included, but if I try to open stp file, I just receive error message? Can it be downloaded somewhere else?

Thank you,

best regards, Jiri

Hi @Jiri.L
You need to set your load options to find the part files for the machine kit. If you install from the mtk file you can set the install path.
Can you open the files individually from your Z:/~ directory?

Hi @Paul

sorry for late response, I was waiting till our company IT guy will be from holiday. We reinstalled postrpocessor and now I am able to open free kit model, I adapted expression for B offset and I just need to test it.

I’ll get back once i will test machining.

Thank you for support

1 Like

Hello @Paul,

I am still strugglin with CAM setup. Where exactly I can set, that postprocessor will use offset from free kit? I adapted expression in V2 assembly, but how will postprocessor know this offset?

Thanks for help

Best regards, Jiri

Hi @Jiri.L
You have to open the post configurator and set the value in the “real machine kinematic” menu option.

here is a video to show you how to access the setting.

PocketNC V1 and V2-10 postprocessor install and configuration document v7.docx (229.4 KB)
Here are the additional instructions