Direct Ethernet Connnection

I am troubleshooting a Ethernet connectivity problem with my PNC 2-10. Every couple days I lose connection, which is connected via Ethernet (this doesn’t to happen if connected via USB. Good news, it immediately comes back and hasn’t happened while a program is running.
Is there a way to direct connect the PNC to the host computer bypassing the router using ethernet?
For help in troubleshooting, I have downloaded many of the log files within three hours after the last disconnection. Can someone direct me as to which of those log files might contain information to help troubleshoot this? And if there’s a way to direct connect to the host computer.
Rob McInerney

Hi @rob_mcinerney

Could you elaborate a bit more on what you mean by “lose connection” and how it immediately comes back?

Fortunately, the machine does not have to be connected to a computer in any way to keep running a program. So, even if you lose connection during program execution, the machine will continue to run as it normally would.

The only way to directly connect the machine to a computer is through the USB connection. Technically you can have a direct ethernet cable connection between the machine and the computer, however the process by which the machine and computer would be communicating is the same as the machine being connected to the router - over the local network.

I had always disconnect troubles with USB! Since I changed to Ethernet, everything works perfect. I connected the PNC and the PCs (I use several at the same time) to a simple switch.

lose = loose = lost!

It comes back about 1 second after it is lost.

Screen shot below,

I am trying to eliminate the Router or Switch from the troubleshooting, that is why I want to direct connect the Host Computer (Windows 11 Machine) to the PNC direct.

That is interesting, I am trying to eliminate my Router or simple switch from the troubleshooting. I have tried 2 routers. I guess I should try a simple switch.

Can you set it to a fixed up address at your router? Mach address reservation or similar type words in the router menu. That solved it for me.

I would like to do that, but my current router with the current firmware (Netgear R9000P) has a documented firmware glitch that won’t allow Static IP. I have some Beta firmware from them, but am afraid to try it!!

If you can easily unwind the beta firmware I’d risk it and give a try.

@rob_mcinerney Ok, got it, thanks for elaborating a bit more. TP suggested the next thing I was going to suggest, the fixed IP.

Otherwise, I am not sure I have any other suggestions for you at this time. Our lead software developer is out of service right now, but he may chime in when he is back on the grid next week.

I also had the issue with my external DRO that is RPI powered. The driver app would stop when disconnected. As soon as i set my DRO to a fixed IP and now it also has no issues.